В Linux обнаружена уязвимость

SecurityLab опубликовал уведомление об уязвимости в ядре Linux, которая позволяет локальному пользователю получить root привилегии на системе.

13 февраля 2008 в 12:02, просмотров: 324

Таким образом, уязвимость опасна тем, что локальный непривилегированный пользователь, который имеет физический или удаленный (например, посредством ssh) доступ к системе и правильные учетные данные (включая доступ к консоли - shell), может получить привилегии учетной записи root или аварийно завершить работу системы.

Уязвимости подвержены все системы, с включенной поддержкой системного вызова vmsplice() и собранные на основе ядра версий с 2.6.17 до 2.6.23.16 и 2.6.24.2. Согласно уведомлениям, уязвимость не распространяется на ядра, которые используют патчи grsecurity, сконфигурированные корректным образом.

SecurityLab выставила для уязвимости низкий рейтинг опасности, поскольку, согласно шкале, используемой для оценки риска опасности уязвимостей, все локальные уязвимости представляют низкий рейтинг опасности. Данная оценка рассчитана на то, что целевая система корректно настроена (с точки зрения безопасности), и не существует возможности получения доступа к ней извне удаленным или локальным неавторизованным пользователем; для локальных учетных записей настроены корректные привилегии доступа, включая доступ к консоли; используются «сильные» пароли и установлены последние обновления для используемого программного обеспечения. Некорректная, с точки зрения безопасности, настройка системы сама по себе является уязвимостью и может усилить влияние других уязвимостей на систему.

Для устранения уязвимости необходимо скачать и установить исправление, доступное на сайте производителя вашего дистрибутива, или пересобрать ядро, доступное на сайте www.kernel.org. После установки исправления потребуется перезагрузка системы.

Источник: SecurityLab.



Партнеры